Jūs esate

Required software for development

I thought it might be interesting to post something about development for the Symbian OS. So, at start we need some software. We'll need two things: a development environment (IDE) & SDK for Symbian OS. Lets start with IDE. Symbian OS has a wonderful page about development: http://developer.symbian.com/main/index.jsp. So, let's go here and look for IDE. Go here: http://www.forum.nokia.com/info/sw.nokia.com/id/dbb8841d-832c-43a6-be13-f78119a2b4cb.html and press Download Now button. Then you need to register and up you go - the package of 203 MB starts downloading. Install it. Then you'll need ActivePerl-5.6.1.635 package (version is very important). Try downloading from here: http://downloads.activestate.com/ActivePerl/Windows/5.6/ (I'm not sure if I downloaded it from here). You'll also need Java Runtime Environment 1.5 (if you don't have it so far). Get it from: http://java.com/en/download/manual.jsp. Now the most interesting part. You need the SDK for Symbian OS. There are different versions of SDK. At first I downloaded the latest version (Symbian OS SDK S60 5th Edition), but I couldn't make it work in my PC. Then I download 3rd Edition - with this everything was ok. The SDK is installed and is running smoothly. One note: be patient. It takes some time to install this SDK... Because I have 3rd Edition of SDK, I can develop applications only for Symbian OS 9.3. Get SDK from: http://www.forum.nokia.com/info/sw.nokia.com/id/ec866fab-4b76-49f6-b5a5-af0631419e9c/S60_All_in_One_SDKs.html And final note - check http://developer.symbian.com/main/documentation/books/books_files/pdf/Getting_Started_final.pdf Good luck ;)

Komentarai

Aš angliškai taip gerai nemoku, tai rašysiu lietuviškai :)
Tai ką gero jau esi symbianui sukūręs?

Kol kas nieko :) Dar tik pradėjau mokytis :)
Žiūrėsiu, kaip seksis :)

Komentuoti