Programavimas

Symbian SDK and Windows Vista

Last two or three days I've tried to install Symbian SDK && Carbide.c++ (get those from: http://www.symbian.org/) into my laptop with Windows Vista. So, here are some impressions about that:
  1. Leave the default paths. So, install Perl to: C:\Perl, Carbide.c++ to C:\Symbian, and SDK to C:\S60. Because otherwise you might expierence a lot of problems.
  2. Work as administrator while developing the software.

How to get node information in block?

I am coding a system for my bachelor theses. And I had & solved a small problem. The problem. I have to types of content types - Record and Group of Records. If I navigate to Group of Records there should be a block with a link saying "Create a record". The problem is that I need to pass some additional argument to the form Record (the node ID of Group of Records). So, my link looks like that: node/add/record?groupid=1001.

Drupal. check_url() & MMS protocol

I was coding a small dialog for my bachelor theses. There is a text box where you can enter an URL address. So, before submitting the form I validate that text box with check_url() function. The problem is, that my address starts with MMS. It's something like that: mms://www.server.lt/directory/file. So, after check_url() function the result is: //www.server.lt/directory/file.

Howto. Execute MS SQL Stored Procedure With C#

At the moment I'm coding a small project for my university. I have to create a simple system on C# and Microsoft SQL Server 2005. So, I need a way (and code) to execute MS SQL Server's Stored Procedures from my C# program.

Drupal - White Page of Death

I was programming with Drupal and got a very ugly mistake - totally blank (white) screen. After some Googling I found that this can be fixed by increasing PHP memory size. Nope, it didn't helped. Then I tried some other tricks, like making a redirection to other page. But no. The solution was very simple: I had to change text encoding to "UTF-8 without BOM" (I used Notepad++ for that). It worked - no white screen ;) P.S. It took about 5 hours to understand that :)

Can not login to Joomla administrator page

Yesterday I had a problem: I couldn't connect to administrator page of Joomla. After some gooogling I found out, that there has to be no blank lines in configuration.php file and (in my case): THIS FILE HAD TO BE ENCODED AS ANSI, NOT AS UTF8. I have no idea why...